Fixing Subscription Update Errors
Tags: subscription update errors, Swann Security app, troubleshooting subscription issues, different platform detected error, subscription not appearing, application not configured for billing, in-app purchase errors, free trial eligibility, Google Play account, Apple App Store account, subscription confirmation, support contact, multiple accounts, subscription mapping, account synchronization, subscription management, subscription cancellation, subscription renewal, subscription troubleshooting, Swann Security account
This article applies to Swann Security app subscriptions for compatible devices.
The most common errors are as follows, but most can be resolved DIY. Click on the one closest to the error you are getting:
- Different Platform/Account Detected
- Subscription does not appear in the Swann Security account
- This version of the application is not configured for billing...
- You're not eligible for the free trial
Error: Different Platform/Account Detected
Causes | Resolutions | |
---|---|---|
Scenario 1 | You changed Google or Apple store account. The old store account is tied to the same Swann Security account ID you are still using. | Please take a screenshot of the subscription confirmation (date and plan must be visible), then send it to our Support team. |
Scenario 2 | Your phone has more than one account (Google Play). One of those accounts was used to subscribe on the same phone (whether it is the same Swann Security account or not). | Use a different Google Play account in your phone to subscribe. |
One Google Pay account can only be mapped to one Swann Security account ID. This is the same for all apps. If you want to subscribe on 2 different Swann Security accounts, then you can either:
- Login via a different Google account on the same phone.
- Login via a different phone to subscribe.
Note: The Swann Security account email address and Google Play/App Store account email address can be different.
Subscription does not appear in the Swann Security account
Account subscriptions and registering for extended warranty are done via the Swann Security app in Android or iOS. It cannot be done via the recorder or a website. The requirement is to ensure you create the Swann Security account via the app, then pair device before you subscribe.
Causes | Resolutions | |
---|---|---|
Scenario 1 | You have a new store account and new Swann Security account (email). Before, you had subscribed to a Swann Security Secure+ Plan, but you unpaired the device and paired it to a new Swann Security account. | Login to your Google or App store account to cancel the old subscription. You must contact Google or Apple to help you with this if you cannot login. Subscribe again using your new store account. |
Scenario 2 | Your device was unpaired from an old account. You created a new Swann Security account and paired your device but cannot see any subscription. | The Swann Security account ID is changed when you create a new account even with the same email address. You will need to resubscribe. |
Scenario 3 | You subscribed to Xtra instead of Unlimited for 2 or more cameras. | The Secure+ Xtra plan only covers 1 device in your Swann Security account. You can manage your subscriptions to move the plan to the camera you want. |
If neither of the above, please go to your app subscription settings in your device to check its status:
-
Apple:
- Go to Settings > [your name] > Subscriptions, OR
- Alternatively, go to Settings > Your Profile > Media & Purchases > View Account > Subscriptions.
-
Google:
- On your Android device, go to subscriptions on Google Play.
This version of the application is not configured for billing through Google Play.
Cause:
The Swann Security app in your phone is not updated or was installed from an APK and not from Google Play.
Resolution:
- Go to Swann Security – Apps on Google Play.
- Uninstall first.
- Then reinstall the app.
You're not eligible for the free trial
New products come with a free trial for one-time registration.
Cause
If you have subscribed to Swann Security before and availed of the free trial, the free trial has already been used and the account/product is no longer valid for free trial. This policy ensures that all our users have the opportunity to experience the service fairly.
Resolution
If you’re interested in exploring our services further with a new product, you can register another email on the Swann Security app and pair your new device there. You may also use a different Google or App store account to subscribe from.